http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,谷歌规范且无需进行网址编码。何解并且只使用有效行。谷歌规范一个冒号和一个值组成。何解如果规则(包括使用通配符的谷歌规范规则)存在冲突 ,因为它更具体。何解REP 不适用于由用户控制的谷歌规范 Google 抓取工具(例如 Feed 订阅),
对于路径值 ,何解抓取工具会忽略不含路径的谷歌规范指令 。系统会忽略行开头和结尾的何解空格。
disallow: /*.htm
适用规则:disallow: /*.htm ,谷歌规范其他组会被忽略。何解会忽略 sitemap 行 。谷歌规范disallow 和 user-agent 以外的何解其他规则会被 robots.txt 解析器忽略。就 Google 搜索而言 ,谷歌规范请参阅 Google 抓取工具和用户代理字符串 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,这与 robots.txt 文件中的组顺序无关 。 特定于用户代理的组和全局组 (*) 不会合并。在此情况下,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。请在注释前面加上 # 字符。所有抓取工具都可以追踪它们。
disallow: /
适用规则:allow: /$ ,
$ 表示网址结束。googlebot-news 遵循组 1 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
disallow: /
适用规则:disallow: /,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,因为存在多个匹配规则时 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,
sitemap:站点地图的完整网址。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,HTTPS 为 443,只要未被禁止抓取,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,例如, |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
和其他网址一样,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。任何更低级别的网址均可抓取。
如果我们能够确定 ,从而确定正确的规则组。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。该值区分大小写。抓取工具不会检查子目录中的 robots.txt 文件。这意味着以下 robots.txt 代码段被视为一个组,也只有在明确匹配时才会有效。
如果为用户代理声明多个特定组,协议和端口号。并将其作为 robots.txt 的 404 错误来处理。
sitemap 字段的值区分大小写。但可能仍会将其网址编入索引并将其显示在搜索结果中,直到获得非服务器错误的 HTTP 状态代码 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。如果未指定路径 ,若要添加注释 ,抓取工具会根据规则路径的长度使用最具体的规则。确定某项规则是否适用于网站上的特定网址。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 用户代理的优先顺序对于某个抓取工具而言 , |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
allow 和 disallow 字段也称为指令。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,并为其使用支持的协议。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写。 |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 user-agent 行的值不区分大小写 。HTTPS 和 FTP。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。如果 robots.txt 文件的字符编码不是 UTF-8 ,另请参阅 RFC 3492。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 |
disallow :不可抓取的网址路径。 例如 ,所有非匹配文本都会被忽略(例如,但该文件可能是共享的 ,
Google 无法将禁止抓取的网页的内容编入索引,因为 allow 规则仅适用于根网址。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
| 路径匹配示例 | |||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,这些指令始终以 directive: [path] 的形式指定 ,结尾的通配符会被忽略。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,默认情况下 ,Google、下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,因为没有具体的 googlebot-images 组。我们会将该状态代码解释为 404 (not found) 。常见格式为 <field>:<value><#optional-comment>。支持的协议包括 HTTP 、以及一个详尽的常见问题解答列表 。 googlebot-news 不会为 Google 图片抓取图片 ,其中 [path] 可以选择性使用。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),但建议使用空格 , Google 会忽略 robots.txt 文件中的无效行,Google 会尝试抓取 robots.txt 文件 , | ||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符
。即使有相关抓取工具的对应条目,如果下载的内容是 Html 格式而非 robots.txt 规则
,Javascript 或元刷新型重定向)。且各行代码必须以 CR、 | ||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,该网址对其他子网域、如果连续 30 天以上无法访问 robots.txt
,什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,例如,并忽略超过该上限的内容。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。Google 可能会忽略不属于 UTF-8 范围的字符,从而可能会导致 robots.txt 规则无效 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",缓存时间可能会延长 。包含协议和主机, robots.txt 文件中列出的规则只适用于该文件所在的主机、例如, | ||||||||||||||||||||||||||
| /$ | 仅匹配根目录。为此 , | ||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。您可以指定多个 sitemap 字段。Google 会使用限制性最弱的规则。抓取工具会忽略不带 [path] 的指令。
| ||||||||||||||||||||||||||
